Add New Page: You are not allowed to add pages Select section/namespace. New page title.
 

PR3 Release Testing

Test:

1) Check OLSRD is running automatically

  • if not restart and begin testing

2) Thrupoint testing against load - iperf

  • WPA None
  • OLSR Secure

3) Encrypted Access Point Creation works

4) Mesh Configuration page allows saves

  • One or more sections are stating that they are full of invalid data
  • meshconfig.lua
    • comment out data types for fields until the “invalid” field is discovered
  • Also Check advanced setting on interface pages to ensure they work

5) Multiple gateways are allowed

6) Release will flash on a 5ghz device (loco's or Buffalo)

7) Release will flash on a device with two physical wireless devices (buffalo)

  • check the interfaces to ensure that they are both running.

Router Test Results

A: "70-50-21" - Picostation

Flashed using Luci interface while plugged in to the router through ethernet.

! Luci interface did not fully reset after “waiting for router” screen. After an extended wait, and indicator lights showing reset a new window was opened and the Luci interface for the new flash was up.

Nodes will not return ICMP traffic on first boot. Once a node is rebooted or the firewall is reset it starts to accept traffic.

1) OLSRD Running

olsrd was running upon first boot Olsrd is shutting down on restart of the node though.

2) Iperf Results

WPANone & OLSRD Secure

Client connecting to 101.50.21.40, TCP port 5001
TCP window size: 23.5 KByte (default)
------------------------------------------------------------
[  3] local 101.50.21.62 port 37470 connected with 101.50.21.40 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.1 sec  16.0 MBytes  13.3 Mbits/sec
------------------------------------------------------------
[  3] local 101.50.21.62 port 37471 connected with 101.50.21.40 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.1 sec  19.2 MBytes  16.0 Mbits/sec
------------------------------------------------------------
[  3] local 101.50.21.62 port 37472 connected with 101.50.21.40 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.1 sec  12.6 MBytes  10.5 Mbits/sec

------------------------------------------------------------
[  3] local 101.50.21.62 port 37473 connected with 101.50.21.40 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.0 sec  18.6 MBytes  15.6 Mbits/sec

------------------------------------------------------------
[  3] local 101.50.21.62 port 37474 connected with 101.50.21.40 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.1 sec  19.5 MBytes  16.1 Mbits/sec

OLSRd-Secure and WPA-NONE OFF

------------------------------------------------------------
Client connecting to 101.50.21.40, TCP port 5001
TCP window size: 23.5 KByte (default)
------------------------------------------------------------
[  3] local 101.50.21.62 port 37484 connected with 101.50.21.40 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.1 sec  17.5 MBytes  14.5 Mbits/sec

------------------------------------------------------------
[  3] local 101.50.21.62 port 37485 connected with 101.50.21.40 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.1 sec  17.8 MBytes  14.7 Mbits/sec

------------------------------------------------------------
[  3] local 101.50.21.62 port 37486 connected with 101.50.21.40 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-11.9 sec  17.1 MBytes  12.1 Mbits/sec

------------------------------------------------------------
[  3] local 101.50.21.62 port 37487 connected with 101.50.21.40 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.1 sec  15.8 MBytes  13.0 Mbits/sec

------------------------------------------------------------
[  3] local 101.50.21.62 port 37488 connected with 101.50.21.40 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.1 sec  18.5 MBytes  15.4 Mbits/sec

3) Setting up an Encrypted Access Point still advertises but **does not give out DHCP to clients**

Got an encrypted access point up and running. Could not get DHCP to give out an IP address to clients.

Settings on node:

/etc/config/wireless

config wifi-iface
        option network 'secure'
        option mode 'ap'
        option device 'radio0'
        option encryption 'psk2'
        option key 'c0MM0t10N!r0ckS!'
        option ssid 'commotion_705076_secure'

/etc/config/network

config interface 'secure'
        option proto 'apif'
        option routing 'olsrd'
        option secure '1'
        option splash '0'
        option ipaddr '103.50.76.1'
        option netmask '255.255.255.0'
        option broadcast '103.50.76.255'
        option reset '0'

/etc/config/dhcp

config dhcp
        option interface 'secure'
        option start '2'
        option limit '150'
        option leasetime '12h'
        option ignore '0'

4) Mesh Configuration Allows Saves

The “host” data type being used for the “Homepage” variable does not accept http://. It was being automatically given http://commotionwireless.net. When the default variable was changed to commotionwireless.net or test.com etc. it was able to be saved.

5) Multiple gateways

6) 5ghz device

7) Multiple Physical Devices

When using a multiple device node we are still getting a interface set for the generic OpenWRT in /etc/config/wireless. This pushes both legitimate Commotion services on the second radio.

 
config wifi-iface
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'
        option device 'radio0'

Mesh over Wire

When using mesh over wire the plug script for olsr was writing the interface over the existing hna in /etc/config/olsrd and therefore killing olsrd.

hna:

config Hna4 'plug'
        option netaddr '0.0.0.0'
        option netmask '0.0.0.0'

corrupted interface:

config Interface 'plug'
        option netaddr '0.0.0.0'
        option netmask '0.0.0.0'
        option interface 'plug'
        option Mode 'ether'
        option Ip4Broadcast '255.255.255.255'

Correct version:

config Interface 'plug'
        option interface 'plug'
        option Mode 'ether'
        option Ip4Broadcast '255.255.255.255'

To fix we are altering /etc/hotplug.d/services/20-olsrd to include the following line

323 --: [ "$(uci_get network "$INTERFACE" meshable 0)" = 1 ] && $DEBUG set_olsrd_if $INTERFACE
323 ++: [ "$(uci_get network "$INTERFACE" meshable 0)" = 1 ] && $DEBUG unset_olsrd_hna4 $INTERFACE && $DEBUG set_olsrd_if $INTERFACE